Resolved
Services have been fully restored and users can now make access requests as normal.
Monitoring
P0 has started rolling back to the last known-good deploy/runtime to immediately restore service.
Identified
Node 24.17.0 introduced a regression (“premature close”) that broke HTTP behavior in a way that affected node-fetch and, in turn, our Okta integration: https://github.com/nodejs/node/issues/63989
Impact is currently limited to the creation of new requests (existing/ongoing requests are not impacted). The P0-API service is unable to resolve policies that relied on Okta group membership.
Okta integration
AWS federated access
AWS SSH sessions that rely on AWS federated access
Investigating
We are currently investigating potential degradation of services that might be affecting the creation of new requests that rely on Okta group membership.
Okta integration
AWS federated access
AWS SSH sessions that rely on AWS federated access